Flickr
Customer Support Issue
Incident Report for Flickr
Resolved
This incident has been resolved.
Posted about 1 month ago. May 15, 2019 - 08:19 PDT
Update
Members may be unable to submit help requests through the contact form on our help center.
Posted about 1 month ago. May 15, 2019 - 06:59 PDT
Investigating
We are currently investigating the issue. If you need urgent assistance, you can reach us at help@flickr.com, thank you for your patience.
Posted about 1 month ago. May 15, 2019 - 06:57 PDT
This incident affected: Support & Help Pages.