Flickr
Site-wide slowness identified
Incident Report for Flickr
Resolved
All clear! Thank you for your patience.
Posted Mar 02, 2020 - 17:34 PST
Identified
We are investigating issues causing members to experience slow loading times. We are working to resolve the issue and appreciate your patience.
Posted Mar 02, 2020 - 17:14 PST
This incident affected: API, Camera Roll, Mobile, Payments, Photo/Video Serving, Search, Stats, Support & Help Pages, Uploads, and Web.