Flickr
Site-wide slowness identified
Incident Report for Flickr
Resolved
All clear! Thank you for your patience.
Posted 24 days ago. Sep 23, 2019 - 12:47 PDT
Identified
We are investigating issues causing members to experience slow loading times. We are working to resolve the issue and appreciate your patience.
Posted 24 days ago. Sep 23, 2019 - 12:23 PDT
This incident affected: API, Camera Roll, Mobile, Payments, Photo/Video Serving, Search, Stats, Support & Help Pages, Uploads, and Web.