Flickr
Site-wide slowness identified
Incident Report for Flickr
Resolved
All clear! Thank you for your patience.
Posted 2 months ago. Jun 06, 2019 - 09:42 PDT
Identified
We are investigating issues causing members to experience slow loading times. We are working to resolve the issue and appreciate your patience.
Posted 2 months ago. Jun 06, 2019 - 09:20 PDT
This incident affected: API, Camera Roll, Mobile, Payments, Photo/Video Serving, Search, Stats, Support & Help Pages, Uploads, and Web.