Flickr

Search

Incident Report for Flickr

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 08:21 PST

Update

We continue to investigate search issues.
Posted Feb 14, 2026 - 14:31 PST

Investigating

We are investigating search issues.
Posted Feb 14, 2026 - 00:02 PST
This incident affected: API, Camera Roll, Mobile, Payments, Photo/Video Serving, Search, Stats, Support & Help Pages, Uploads, and Web.