Flickr
Delay in activating Pro subscriptions
Incident Report for Flickr
Resolved
All clear! Thanks for your patience.
Posted about 2 months ago. Aug 29, 2019 - 12:50 PDT
Monitoring
A fix for the underlying problem causing this issue has been deployed. We’re monitoring the impact and will update here once we've confirmed the issue is resolved.
Posted about 2 months ago. Aug 29, 2019 - 10:45 PDT
Investigating
Our subscriptions payments processor is investigating an issue that is delaying the activation of a small number of new Pro subscriptions.
Posted about 2 months ago. Aug 28, 2019 - 12:09 PDT
This incident affected: Payments.