Flickr
PhotoServing performance is degraded
Incident Report for Flickr
Resolved
The Photoserving issue has been resolved. Thank you for your patience.
Posted 5 months ago. Jun 03, 2019 - 16:41 PDT
Identified
We are currently investigating a photoserving issue. We appreciate your patience.
Posted 5 months ago. Jun 03, 2019 - 14:55 PDT
This incident affected: Photo/Video Serving.