Flickr

Video Playback and Download not working properly

Incident Report for Flickr

Postmortem

Code Push, Jubilee

Posted Aug 14, 2025 - 22:28 PDT

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 11:44 PDT

Investigating

We are currently investigating the issue some community members are having with video playback and video downloads.
Posted Jul 31, 2025 - 06:23 PDT
This incident affected: Photo/Video Serving.