Flickr
Photo sharing
Incident Report for Flickr
Resolved
This incident has been resolved.
Posted May 21, 2024 - 14:33 PDT
Update
We are continuing to monitor for any further issues.
Posted May 21, 2024 - 14:18 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2024 - 14:14 PDT
Identified
The issue with sharing Albums has been identified and we're currently rolling out a fix. Thanks for your patience!
Posted May 21, 2024 - 13:17 PDT
Investigating
We are currently investigating issues with sharing Albums. We appreciate your patience as we investigate.
Posted May 21, 2024 - 13:08 PDT
This incident affected: Web.