Flickr
Explore - Investigation in progress
Incident Report for Flickr
Resolved
This incident has been resolved.
Posted May 17, 2021 - 10:06 PDT
Monitoring
We were able to get Explore back up over the weekend. We'll be monitoring its performance for a bit before calling this incident resolved.
Posted May 17, 2021 - 08:59 PDT
Update
We're continuing to work on bringing Explore back up. At this time, we expect Explore to remain down through Monday, May 17. In the meantime, we'll plan to highlight photography from a few different groups on this page.

We apologize for the disruption. Please know that we are actively working on this, and this remains our top priority.
Posted May 14, 2021 - 13:10 PDT
Update
We're continuing to work on bringing Explore back online. We continue to estimate that Explore will be back on Saturday, May 15. In the meantime, you'll notice a banner on the Explore page that points folks to other places to find inspiring photos. Thanks for your continued patience in the meantime.
Posted May 13, 2021 - 15:01 PDT
Update
We're continuing to work on getting Explore back up and running. Our current estimate to have Explore back up is Saturday, May 15. We apologize for the inconvenience and appreciate your continued patience.
Posted May 13, 2021 - 08:59 PDT
Identified
Explore is temporarily down. This is also impacting the trending tags page. We're working on getting things back up and running, but Thursday's Explore page (5/13/21) will likely be delayed as well. Thanks for your continued patience and please stay tuned.
Posted May 12, 2021 - 15:12 PDT
Investigating
We are aware of a delay in preparing today's Explore page. This is also impacting the trending tags page. We apologize for the inconvenience, and thanks for your patience.
Posted May 11, 2021 - 19:15 PDT
This incident affected: Explore.