Flickr
photoserving latency
Incident Report for Flickr
Resolved
This has been resolved and photo serving is back to normal.
Posted 14 days ago. Oct 03, 2019 - 15:29 PDT
Investigating
Currently we are experiencing photo serving latency and investigating the issue.
Posted 14 days ago. Oct 03, 2019 - 15:24 PDT
This incident affected: Photo/Video Serving.