Flickr
Payment issues using IAP
Incident Report for Flickr
Resolved
We have identified a long term fix for the issue. Currently, the workaround is to manage your Flickr Pro Subscription through your original method of purchase (either the mobile app or web.) as seen in this article https://www.flickrhelp.com/hc/en-us/articles/4404058158612-Manage-Your-Flickr-Pro-Subscription-and-Payment-Options
Posted Jan 24, 2022 - 13:41 PST
Update
We will be pushing out a fix for this shortly.
Posted Jan 24, 2022 - 11:39 PST
Identified
The issue has been identified and isolated to users who are using in App Purchases and have their payment method expired. The work around is to update the payment method through their mobile app and not through the desktop experience. We will update with more information shortly.
Posted Jan 24, 2022 - 08:08 PST
Investigating
Some Pro members might have issues updating their payment method.
Posted Jan 24, 2022 - 07:31 PST
This incident affected: Payments.