Flickr

Photo Page navigation issue

Incident Report for Flickr

Resolved

This incident has been resolved.
Posted Feb 14, 2023 - 13:23 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2023 - 10:12 PST

Identified

We are currently investigating an issue with navigating from photostreams to individual photos. We appreciate your patience.
Posted Feb 14, 2023 - 09:49 PST
This incident affected: Web.