Flickr

Photos fail to load or upload

Incident Report for Flickr

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 10:33 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2025 - 09:58 PDT

Identified

The issue has been identified for uploads and a fix is in place, but the upload queue is going to take some time to process. Photo and Video serving services have returned to normal.
Posted Jul 23, 2025 - 08:27 PDT

Investigating

We are currently investigating this issue.
Posted Jul 23, 2025 - 04:02 PDT
This incident affected: Photo/Video Serving, Uploads, and Web.