Flickr
Uploads issues
Incident Report for Flickr
Resolved
All clear! Thank you for your patience.
Posted 28 days ago. Sep 18, 2019 - 18:35 PDT
Identified
We are investigating issues causing members to experience slow or timed out uploads. We are working to resolve the issue and appreciate your patience.
Posted 28 days ago. Sep 18, 2019 - 17:16 PDT
This incident affected: API, Camera Roll, Mobile, Payments, Photo/Video Serving, Search, Stats, Support & Help Pages, Uploads, and Web.