Flickr
Upload woes
Incident Report for Flickr
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 13:16 PDT
Investigating
We are currently investigating an issue where uploads are stuck at the "verifying" state.
Posted Aug 24, 2020 - 12:14 PDT
This incident affected: Uploads.