Flickr
Follow button not working
Incident Report for Flickr
Resolved
Members should now be able to follow other members. Apologies for any inconvenience.
Posted 28 days ago. May 20, 2019 - 07:08 PDT
Investigating
We are currently investigating this issue.
Posted 28 days ago. May 20, 2019 - 06:49 PDT
This incident affected: Mobile and Web.