Flickr

Site slowness and failed uploads

Incident Report for Flickr

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 06:59 PST

Investigating

We are currently investigating issues with some members experiencing site slowness, failed uploads and bad pandas. We apologize for the trouble and appreciate your patience.
Posted Mar 03, 2026 - 11:08 PST
This incident affected: Uploads and Web.