Flickr

Service Degredation - Album Issues

Incident Report for Flickr

Resolved

We've rolled out a fix for the various Album issues and everything should be working as intended. We appreciate your patience and apologize for any frustrations this may have caused.
Posted Jun 25, 2025 - 09:09 PDT

Investigating

We're currently investigating issues with loading and sorting Albums. Issue was first identified at 9:36AM EDT. Thanks for your patience.
Posted Jun 25, 2025 - 08:10 PDT
This incident affected: Web.