Flickr

Issues with faves follows and privacy settings

Incident Report for Flickr

Resolved

This incident has been resolved.
Posted Mar 22, 2024 - 08:31 PDT

Investigating

We are currently investigating this issue.
Posted Mar 22, 2024 - 06:27 PDT
This incident affected: API and Web.