Flickr
Site-wide slowness identified
Incident Report for Flickr
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 12, 2019 - 18:43 PDT
Identified
We are investigating issues causing members to experience slow loading times. We are working to resolve the issue and appreciate your patience.
Posted about 1 month ago. Jul 12, 2019 - 13:05 PDT
This incident affected: API, Camera Roll, Mobile, Payments, Photo/Video Serving, Search, Stats, Support & Help Pages, Uploads, and Web.