We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 15:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 15:07 PDT
Update
Flickr is back online, but we are still experiencing upload failures. We continue to investigate. Thank you for your patience.
Posted Oct 20, 2025 - 12:19 PDT
Identified
We’re sorry! Flickr is temporarily unavailable due to a major issue affecting Amazon Web Services, and we are working with them on a fix.
Posted Oct 20, 2025 - 09:53 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 07:22 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 04:58 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 04:19 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 02:40 PDT
Update
We’re sorry! Flickr is temporarily unavailable due to a major issue affecting Amazon Web Services, and we are working with them on a fix.
Posted Oct 20, 2025 - 00:41 PDT
Investigating
We're investigating site issues. We appreciate your patience.
Posted Oct 20, 2025 - 00:10 PDT
This incident affected: API, Camera Roll, Mobile, Payments, Photo/Video Serving, Search, Stats, Support & Help Pages, Uploads, Web, Login, and Explore.